staging.inyokaproject.org

smartctl, badblocks, dd mit zero, hdparm

Status: Ungelöst | Ubuntu-Version: Kubuntu 14.04 (Trusty Tahr)
Antworten |

herrmeier

Anmeldungsdatum:
5. Oktober 2006

Beiträge: Zähle...

Vorab Danke fürs Lesen! Ich freue mich auf Euren input!

Fragen Kurzversion:

  • Eine Festplatte hat badblocks. Wie kann ich diese markieren/reparieren, so dass die Platte nicht weggeschmissen werden muss. Wie verhindere ich, dass die Benutzung von badblocks so lange dauert? Gibt es eine schnellere Herangehensweise?

  • soweit ich das sehe, ist hauptsächlich die boot-Partition von ubuntu (Linux1) betroffen, wie repariere ich diese, sobald ich das ddrescue-image auf die reparierte oder eine neue Festplatte zurückgespielt habe?

  • wie kann ich die Ausgabe von badblocks am Besten mit tee sowohl auf dem Display anzeigen als auch in eine LOG-Datei schreiben. Ich mache dies momentan mit:

1
sudo smartctl -t long /dev/sdg 2>&1 | tee -a /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/smartctl-t_long.txt

und bin mir etwas unsicher, weil da nichts rauskommt, was aber auch daran liegen kann, dass die Ausgabe erst mit sudo smartctl -a /dev/sdg erfolgt. Nur zur Sicherheit.

Situation

Eine Laptop-Platte bootete plötzlich nicht mehr, nachdem das parallel installierte Win7 bei der Benutzung mit itunes und iPhone-backup, 16GB evtl. vollgelaufen ist. Es handelt sich nicht um meine Geräte, bitte kein closed-source-bashing.

Recherche

Ich bin nach diesen Anleitungen vorgegangen.
http://www.finnchristiansen.de/2013/12/27/datenrettung-mit-linux/
dd aus ubuntuuserswiki
Datenrettung aus ubuntuuserswiki

Backup

dd

Zunächst habe ich versucht ein schnelles dd zu machen.

1
2
3
4
5
6
sudo dd if=/dev/sdd of=/media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/$(date -I)toshiba_m11_122_dd_image_250GB.img bs=10M
[sudo] password for user:
dd: Fehler beim Lesen von »/dev/sdd“: Eingabe-/Ausgabefehler
5906+1 Datensätze ein
5906+1 Datensätze aus
61934141440 Bytes (62 GB) kopiert, 2566,1 s, 24,1 MB/s

Die meisten Daten habe ich mit ddrescue, fdisk -l, mount -o loop,offset und rsync bereits "gerettet"

ddrescue

Die meisten Daten habe ich mit ddrescue, fdisk -l, mount -o loop,offset und rsync bereits "gerettet"

1
2
sudo ddrescue -n /dev/sdg /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/$(date -I)toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/ext4MyBook/backup
/2014-12-03toshiba_m11-122_dd/$(date -I)toshiba_m11_122_dd_image_250GB_backup_schnell_full.log

fdisk -l

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22

/media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test$ sudo fdisk -l 2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img
[sudo] password for user:

Disk 2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img: 250.1 GB, 250059350016 bytes
255 Köpfe, 63 Sektoren/Spur, 30401 Zylinder, zusammen 488397168 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Festplattenidentifikation: 0xf79f4b24

                                                     Gerät  boot.     Anfang        Ende     Blöcke   Id  System
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img1   *        2048     3074047     1536000   27  Hidden NTFS WinRE
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img2         3074048   120963876    58944914+   7  HPFS/NTFS/exFAT
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img3       473669632   488396799     7363584   17  Verst. HPFS/NTFS
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img4       120965118   473669631   176352257    5  Erweiterte
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img5       120965120   175124479    27079680   83  Linux
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img6       459278336   473669631     7195648   82  Linux Swap / Solaris
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img7       175126528   446207999   135540736   83  Linux
2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img8       446210048   459276287     6533120   83  Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Hidden NTFS WinRE

1
2
3
4
5
2048*512=1048576
$ mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7re
sudo mkdir /media/user/win7re && sudo chown -R user:users /media/user/win7re
sudo mount -o loop,offset=1048576 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/win7re
sudo rsync --update -ahv --progress --partial /media/user/win7re/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7re

HPFS/NTFS/exFAT

1
2
3
4
5
6

3074048*512=1573912576
$ mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7
sudo mkdir /media/user/win7 && sudo chown -R user:users /media/user/win7
sudo mount -o loop,offset=1573912576 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/win7
sudo rsync --update -ahv --progress --partial /media/user/win7/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7/

Verst. HPFS/NTFS

1
2
3
4
5
473669632*512=242518851584
mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7install
sudo mkdir /media/user/win7install && sudo chown -R user:users /media/user/win7install
sudo mount -o loop,offset=242518851584 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/win7install
sudo rsync --update -ahv --progress --partial /media/user/win7install/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/win7install/

Linux1

1
2
3
4
120965120*512=61934141440
mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/1inux1
sudo mkdir /media/user/linux1 && sudo chown -R user:users /media/user/linux1
sudo mount -o loop,offset=61934141440 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/linux1

abbruch an dieser Stelle sudo rsync --update -ahv --progress --partial /media/user/linux1/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/linux1/

hat nicht geklappt!

betreffender syslog-Auszug zu Linux1-Partitions-Fehler:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

Dec  4 21:23:15 hostname kernel: [216136.507082] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:23:15 hostname kernel: [216136.507140] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:23:15 hostname kernel: [216136.507175] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:23:15 hostname kernel: [216136.507233] FAT-fs (loop3): bogus number of reserved sectors
Dec  4 21:23:15 hostname kernel: [216136.507236] FAT-fs (loop3): Can't find a valid FAT filesystem
Dec  4 21:23:15 hostname kernel: [216136.507764] XFS (loop3): bad magic number
Dec  4 21:23:15 hostname kernel: [216136.507772] XFS (loop3): SB validate failed with error 22.
Dec  4 21:23:15 hostname kernel: [216136.508359] FAT-fs (loop3): bogus number of reserved sectors
Dec  4 21:23:15 hostname kernel: [216136.508361] FAT-fs (loop3): Can't find a valid FAT filesystem
Dec  4 21:25:53 hostname kernel: [216295.044424] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:33:43 hostname kernel: [216764.849396] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:34:18 hostname kernel: [216800.769057] EXT4-fs (loop3): VFS: Can't find ext4 filesystem
Dec  4 21:37:21 hostname kernel: [216983.519125] EXT4-fs (loop3): warning: mounting fs with errors, running e2fsck is recommended
Dec  4 21:37:21 hostname kernel: [216983.519357] EXT4-fs (loop3): mounted filesystem with ordered data mode. Opts: (null)
Dec  4 21:37:57 hostname kernel: [217019.270484] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3407873: comm rsync: deleted inode referenced: 5242944
Dec  4 21:38:00 hostname kernel: [217022.400251] EXT4-fs error (device loop3): htree_dirblock_to_tree:920: inode #3596331: block 22822911: comm rsync: bad entry in directory: rec_len is smaller than minimal - offset=0(294912), inode=0, rec_len=0, name_len=0
Dec  4 21:40:56 hostname kernel: [217198.268564] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3440651: comm rsync: deleted inode referenced: 5242895
Dec  4 21:40:56 hostname kernel: [217198.275173] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3440651: comm rsync: deleted inode referenced: 5242901
Dec  4 21:40:56 hostname kernel: [217199.040002] EXT4-fs (loop4): warning: checktime reached, running e2fsck is recommended
Dec  4 21:40:56 hostname kernel: [217199.040392] EXT4-fs (loop4): mounted filesystem with ordered data mode. Opts: (null)
Dec  4 21:41:11 hostname kernel: [217213.473315] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3408526: comm rsync: deleted inode referenced: 5242943
Dec  4 21:41:18 hostname kernel: [217220.906388] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3408533: comm rsync: deleted inode referenced: 5242941
Dec  4 21:42:21 hostname kernel: [217284.294689] EXT4-fs (loop3): error count since last fsck: 24
Dec  4 21:42:21 hostname kernel: [217284.294693] EXT4-fs (loop3): initial error at time 1416522360: __ext4_get_inode_loc:3852: inode 3481644: block 13636130
Dec  4 21:42:21 hostname kernel: [217284.294697] EXT4-fs (loop3): last error at time 1417725678: ext4_lookup:1437: inode 3408533
Dec  4 22:21:49 hostname kernel: [219654.816045] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3571738: comm rsync: deleted inode referenced: 5251074
Dec  4 22:27:21 hostname kernel: [219987.091812] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245867
Dec  4 22:27:21 hostname kernel: [219987.091904] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245876
Dec  4 22:27:21 hostname kernel: [219987.091954] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245871
Dec  4 22:27:21 hostname kernel: [219987.091992] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245875
Dec  4 22:27:21 hostname kernel: [219987.092027] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245870
Dec  4 22:27:21 hostname kernel: [219987.092062] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245866
Dec  4 22:27:21 hostname kernel: [219987.092098] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245889
Dec  4 22:27:21 hostname kernel: [219987.092131] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245874
Dec  4 22:27:21 hostname kernel: [219987.092165] EXT4-fs error (device loop3): ext4_lookup:1437: inode #3629122: comm rsync: deleted inode referenced: 5245836

Linux2

1
2
3
4
5

175126528*512=89664782336
mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/1inux2 && sudo mkdir /media/user/linux2 && sudo chown -R user:users /media/user/linux2
sudo mount -o loop,offset=89664782336 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/linux2
sudo rsync --update -ahv --progress --partial /media/user/linux2/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/linux2/

Linux3

1
2
3
4
446210048*512=228459544576
mkdir /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/1inux3 && sudo mkdir /media/user/linux3 && sudo chown -R user:users /media/user/linux3
sudo mount -o loop,offset=228459544576 /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/2014-12-03toshiba_m11_122_ddrescue_image_schnell_250GB.img /media/user/linux3
sudo rsync --update -ahv --progress --partial /media/user/linux3/* /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/linux3/

Festplattenstatus

smartctl -a /dev/sdg

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
smartctl -a /dev/sdg
smartctl 6.2 2013-07-26 r3841 [i686-linux-3.13.0-40-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Travelstar 5K500.B
Device Model:     Hitachi HTS545025B9A300
Serial Number:    xxxxxxxxxxxxxxxxxxxx
LU WWN Device Id: 5 000cca 5f3ea6220
Firmware Version: PB2OC64G
User Capacity:    250.059.350.016 bytes [250 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    5400 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 6
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Fri Dec  5 12:59:27 2014 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
Warning: This result is based on an Attribute check.

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      ( 120)	The previous self-test completed having
					the read element of the test failed.
Total time to complete Offline 
data collection: 		(  645) seconds.
Offline data collection
capabilities: 			 (0x5b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  83) minutes.
SCT capabilities: 	       (0x003d)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       65536
  2 Throughput_Performance  0x0005   100   100   040    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0007   206   206   033    Pre-fail  Always       -       1
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       1290
  5 Reallocated_Sector_Ct   0x0033   095   095   005    Pre-fail  Always       -       276
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   040    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0012   081   081   000    Old_age   Always       -       8434
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       1228
191 G-Sense_Error_Rate      0x000a   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       35258395
193 Load_Cycle_Count        0x0012   099   099   000    Old_age   Always       -       13672
194 Temperature_Celsius     0x0002   203   203   000    Old_age   Always       -       27 (Min/Max 11/51)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       313
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       390
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0
223 Load_Retry_Count        0x000a   100   100   000    Old_age   Always       -       0

SMART Error Log Version: 1
ATA Error Count: 1705 (device log contains only the most recent five errors)
	CR = Command Register [HEX]
	FR = Features Register [HEX]
	SC = Sector Count Register [HEX]
	SN = Sector Number Register [HEX]
	CL = Cylinder Low Register [HEX]
	CH = Cylinder High Register [HEX]
	DH = Device/Head Register [HEX]
	DC = Device Command Register [HEX]
	ER = Error register [HEX]
	ST = Status register [HEX]
Powered_Up_Time is measured from power on, and printed as
DDd+hh:mm:SS.sss where DD=days, hh=hours, mm=minutes,
SS=sec, and sss=millisec. It "wraps" after 49.710 days.

Error 1705 occurred at disk power-on lifetime: 8397 hours (349 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 04 fc 37 52 45  Error: UNC 4 sectors at LBA = 0x055237fc = 89274364

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  25 00 08 f8 37 52 40 00      06:29:30.900  READ DMA EXT
  25 00 08 f8 37 52 40 00      06:29:27.100  READ DMA EXT
  25 00 08 78 54 20 40 00      06:29:25.900  READ DMA EXT
  25 00 08 f8 67 8c 40 00      06:29:22.100  READ DMA EXT
  25 00 08 f8 67 8c 40 00      06:29:18.300  READ DMA EXT

Error 1704 occurred at disk power-on lifetime: 8397 hours (349 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 04 fc 37 52 45  Error: UNC 4 sectors at LBA = 0x055237fc = 89274364

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  25 00 08 f8 37 52 40 00      06:29:27.100  READ DMA EXT
  25 00 08 78 54 20 40 00      06:29:25.900  READ DMA EXT
  25 00 08 f8 67 8c 40 00      06:29:22.100  READ DMA EXT
  25 00 08 f8 67 8c 40 00      06:29:18.300  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:14.600  READ DMA EXT

Error 1703 occurred at disk power-on lifetime: 8397 hours (349 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 08 f8 67 8c 42  Error: UNC 8 sectors at LBA = 0x028c67f8 = 42756088

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  25 00 08 f8 67 8c 40 00      06:29:22.100  READ DMA EXT
  25 00 08 f8 67 8c 40 00      06:29:18.300  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:14.600  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:10.800  READ DMA EXT
  25 00 08 70 bb 8f 40 00      06:29:07.100  READ DMA EXT

Error 1702 occurred at disk power-on lifetime: 8397 hours (349 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 08 f8 67 8c 42  Error: UNC 8 sectors at LBA = 0x028c67f8 = 42756088

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  25 00 08 f8 67 8c 40 00      06:29:18.300  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:14.600  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:10.800  READ DMA EXT
  25 00 08 70 bb 8f 40 00      06:29:07.100  READ DMA EXT
  25 00 08 78 bb 8f 40 00      06:29:07.000  READ DMA EXT

Error 1701 occurred at disk power-on lifetime: 8397 hours (349 days + 21 hours)
  When the command that caused the error occurred, the device was active or idle.

  After command completion occurred, registers were:
  ER ST SC SN CL CH DH
  -- -- -- -- -- -- --
  40 51 08 78 38 e2 47  Error: UNC 8 sectors at LBA = 0x07e23878 = 132266104

  Commands leading to the command that caused the error were:
  CR FR SC SN CL CH DH DC   Powered_Up_Time  Command/Feature_Name
  -- -- -- -- -- -- -- --  ----------------  --------------------
  25 00 08 78 38 e2 40 00      06:29:14.600  READ DMA EXT
  25 00 08 78 38 e2 40 00      06:29:10.800  READ DMA EXT
  25 00 08 70 bb 8f 40 00      06:29:07.100  READ DMA EXT
  25 00 08 78 bb 8f 40 00      06:29:07.000  READ DMA EXT
  25 00 08 70 bb 8f 40 00      06:29:03.300  READ DMA EXT

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed: read failure       80%      8432         120965123
# 2  Extended offline    Completed: read failure       80%      8422         120965123

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

weitere Vorgehensweise?

Teilweise wird mir vorgeschlagen die Hitachi-Platte mit dd "auszunullen" 🇬🇧 oder mit hdparm die Platte zu verschlüsseln und anschließend wieder zu entschlüsseln 🇬🇧

frostschutz

Avatar von frostschutz

Anmeldungsdatum:
18. November 2010

Beiträge: 7795

herrmeier schrieb:

  • Eine Festplatte hat badblocks. Wie kann ich diese markieren/reparieren, so dass die Platte nicht weggeschmissen werden muss. Wie verhindere ich, dass die Benutzung von badblocks so lange dauert? Gibt es eine schnellere Herangehensweise?

Teilweise wird mir vorgeschlagen die Hitachi-Platte mit dd "auszunullen" 🇬🇧

Wenn du die Platte mit Nullen überschreibst, sollte sie defekte Sektoren remappen. Insofern ist das der ganz richtige Vorschlag.

Aber das ist nur kosmetisch. Defekte Sektoren lassen sich nicht reparieren; und Reservesektoren gehen auf die Performanz (zusätzliche Seeks wann immer so ein Sektor geschrieben oder gelesen werden muss). Darüber hinaus kann sich der Defekt auch weiter ausbreiten. Vertrauenswürdig ist so ein Medium jedenfalls nicht mehr, da es schon Daten verloren hat.

Am Ende bleibt nur eine neue Festplatte... das sind nun mal Verschleißteile. Du hast Reallocated und Pending Sectoren, das Ding ist hinüber.

Hans9876543210

Anmeldungsdatum:
2. Januar 2011

Beiträge: 3741

Moin,

herrmeier schrieb:

1
sudo smartctl -t long /dev/sdg 2>&1 | tee -a /media/user/ext4MyBook/backup/2014-12-03toshiba_m11-122_dd/test/smartctl-t_long.txt

und bin mir etwas unsicher, weil da nichts rauskommt, was aber auch daran liegen kann, dass die Ausgabe erst mit sudo smartctl -a /dev/sdg erfolgt. Nur zur Sicherheit.

Soweit ich weiß, wird die Ausgabe des Testlaufs hier angezeigt:

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed: read failure       80%      8432         120965123
# 2  Extended offline    Completed: read failure       80%      8422         120965123

Benno-007

Anmeldungsdatum:
28. August 2007

Beiträge: 29240

Ein Thema mit Fragen mit Inhaltsverzeichnis hab ich hier auch noch nicht erlebt - alle Achtung. ☺ Du kannst mit ddrescue noch ein Log aktivieren und ein Image statt Dateien...ach hast du ja auch schon. Man sieht, du kennst dich aus.

Was du noch machen kannst:

       -r, --retries=<n>
              exit after given retries (-1=infinity) [0]

Kannst es je nach Wichtigkeit ja mal auf 10.000 oder -1 für unendlich stellen und die ganze Nacht Sektoren weiterretten lassen.

Oder mit debugfs schauen, ob die Dateien der defekten Sektoren überhaupt relevant sind:

http://smartmontools.sourceforge.net/badblockhowto.html#e2_example1

Ansonsten hast du eben evtl. zumindest Dateibestandteile noch vorhanden mit Dateiname oder müsstest mit Datenrettung#PhotoRec dein Glück versuchen, wenn der Dateiname schon fehlt bzw. Bruchstücke "namenslos" umherirren, aber noch lesbar sind.

ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       65536
  2 Throughput_Performance  0x0005   100   100   040    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0007   206   206   033    Pre-fail  Always       -       1
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       1290
  5 Reallocated_Sector_Ct   0x0033   095   095   005    Pre-fail  Always       -       276
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   040    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0012   081   081   000    Old_age   Always       -       8434
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       1228
191 G-Sense_Error_Rate      0x000a   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       35258395
193 Load_Cycle_Count        0x0012   099   099   000    Old_age   Always       -       13672
194 Temperature_Celsius     0x0002   203   203   000    Old_age   Always       -       27 (Min/Max 11/51)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       313
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       390
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0
223 Load_Retry_Count        0x000a   100   100   000    Old_age   Always       -       0

...

SMART Error Log Version: 1
ATA Error Count: 1705 (device log contains only the most recent five errors)

Die Platte selber hat je ca. 300 Fehler in allen drei Sektorfehlerspalten. Die ist also weniger als scheinlebendig, mehr so quasitot. Beispielsweise kann der Kopf gecrasht sein, dadurch blättern Magnetschichten ab. Das wird dann wie ein Flächenbrand mit jeder Umdrehung immer schlimmer. Bis die Platte vielleicht sogar steckenbleibt oder ab und zu ausgeht (hab ich bei einer externen erlebt, welche laufend nur ca. 20 cm tief auf den Tisch fiel).

Das hat also nix mehr mit vereinzelten 2-3 Fehlern zu tun, die über Jahre nicht mehr werden. Selbst 30 oder 100 Fehler wären schon fatal, du hast jedoch 1000 und es werden mit Sicherheit immer mehr. Das ist das eigentliche Problem, nicht die bereits vorhandenen Fehler: Durch die krassen Ursachen werden es mehr Fehler, du kannst den Verfall nicht mehr stoppen. Kannst du ja gern testen, nach einem weiteren Test in paar Stunden oder gar Tagen, falls die Platte da noch einen Mucks von sich gibt.

Grüße, Benno

herrmeier

(Themenstarter)

Anmeldungsdatum:
5. Oktober 2006

Beiträge: 297

DANKE!

Vielen Dank für Euren input!!

weitere Vorgehensweise

Klar

Ich hatte es mir schon gedacht und die neue Platte schon bestellt. Ist jetzt eine Samsung EVO 840 für 110,-€ bei Jeff Bezos gekauft, aber keine pro die laut golem 2 Petabyte hält;-) Und eine externe Platte(WD MyBook für MAC=20EUR<), da werden jetzt per cron und raspberry pi die backups gemacht und ab und zu ein dd-image->mit 7z, mx=9 komprimiert. Dann dürften zumindest die Daten 1mal gesichert sein ⇒ kein single-point-of-failure.

Unklar

Rückspielen des ddrescue-n-Images

Jetzt ist nur die Frage der Neubespielung der Platte. Ich gehe davon aus, dass das ddrescue-Image zwar die meisten Dateien hat, allerdings fehlt zumindest die Boot-Möglichkeit, die ich reparieren müsste. Wie würdet Ihr grub reparieren? Ich kenne leider das neue grub immer noch nicht.

booten:

Der Laptop will momentan allerdings noch nicht einmal von USB-Stick (usb 3.0, usb 2.0) bzw. Knoppix DVD booten und hängt immer im Netzwerkboot fest. Scheinbar kann ich dies aber auch nicht im Bios ändern. Vielleicht liegt es an einem fehlenden BIOS-upgrade oder an der fehlende/fehlerhaften Platte. Hat schon jemand unter Linux einem toshiba Laptop das BIOS upgedated?

Benno-007

Anmeldungsdatum:
28. August 2007

Beiträge: 29240

Fast übersehn.

Ein Image der gesamten Festplatte braucht keine GRUB 2/Reparatur (Abschnitt „chroot-Methode“).

Die Bootreihenfolge kann man in jedem BIOS beeinflussen. First Boot Device auf die HDD. Netzwerkboot (PXE) ggf. deaktivieren oder nach hinten schieben. Vielleicht das BIOS auch mal resetten.

Antworten |